Project

General

Profile

Feature #1266

Add new setting for the maximum amount of data to Keep

Added by Kevin Frechette 4 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Start date:
08/05/2022
Due date:
% Done:

0%

Estimated time:
Resolution:
Won't Fix

Description

Max size of Data to Keep (0 for all)

History

#1 Updated by Kevin Frechette 4 months ago

  • Status changed from New to Feedback

On Fri, Aug 5, 2022 at 3:13 PM Kevin Frechette <> wrote:
I started looking into adding the "Max size of Data to Keep" setting and now I remember why I didn't add this in the first place. The problem is in order to add this you would need to periodically add up the size of all the data or determine the size when the program starts and dynamically track it. Both of these options have a fair amount of overhead. We could minimize the overhead by reducing the frequency of checking the amount but I still have some concerns about it.

#2 Updated by Kevin Frechette 4 months ago

On Fri, Aug 5, 2022 at 5:23 PM Tammy Bravo <> wrote:
Let's skip it for now. Thanks for looking into it. If I hear concerns from others we can reconsider.

#3 Updated by Kevin Frechette 4 months ago

On Mon, Aug 8, 2022 at 7:45 AM Kevin Frechette <> wrote:
In the future if you decide it is really needed we could add this and only check daily to provide some limitation of the size without too much overhead. The default would be not to check at all so the overhead would only be there for users that specifically enable it.

#4 Updated by Kevin Frechette 4 months ago

  • Assignee changed from Kevin Frechette to Tammy Bravo

#5 Updated by Kevin Frechette 2 months ago

  • Resolution set to Won't Fix
  • Assignee deleted (Tammy Bravo)
  • Status changed from Feedback to Closed

Also available in: Atom PDF