Project

General

Profile

Bug #1308

delta in SAC file is incorrect

Added by Kevin Frechette 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Start date:
03/15/2024
Due date:
% Done:

0%

Estimated time:
Resolution:

Description

The delta / sample rate in the SAC file does not match the value in the serial properties.


Related issues

Related to Feature #1219: Add maximum sample rate valueClosed2021-12-07

History

#1 Updated by Kevin Frechette 2 months ago

The sample rate for a SeismicPi device with a sample rate of 128 sps (startup string = "8\nc\ns\ne\n") is written to a SAC file with a sample rate of 32 sps.

#2 Updated by Kevin Frechette 2 months ago

This is not a bug. The sample rate for a local source is currently restricted to a maximum of 32 sps.

edu.iris.epo.jamaseis.device.SerialReaderImp
private static final int MAX_SAMPLE_RATE = 32;

#3 Updated by Kevin Frechette 2 months ago

#4 Updated by Kevin Frechette 2 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF