Project

General

Profile

Bug #540

Email not working

Added by Rob Newman almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
04/16/2014
Due date:
% Done:

100%

Estimated time:
Resolution:
Fixed

Description

Begin forwarded message:

From: Derick Hess <>
Subject: Re: hdf5 temporary volume
Date: April 16, 2014 at 1:12:20 PM PDT
To: Steve Azevedo <>
Cc: Inge Watson <>, Sandra Stromme <>, Rob Newman <>

I've messed with various server settings in my code trying to send email via
smtp but it doesn't seem to be working. The web form portion and generating
the data seems to work just fine. Just can't email out the download link to the user.

History

#1 Updated by Rob Newman almost 10 years ago

On 04/16/2014 02:22 PM, Sandra Stromme wrote:

HI,

I don't think any IRIS DMC personnel have been given the link to the form - can we have that? I don't > know what kind of release criteria should be done with this, but I'm pretty sure someone at the DMC
needs to double check that access to restricted data works and that data only goes out the door
encrypted and to the right people. Also, have Passcal peeps who deliver ph5 been informed to deliver
data to the new area?

Thanks,

Sandy

#2 Updated by Rob Newman almost 10 years ago

On Apr 16, 2014, at 14:06, Steve Azevedo <> wrote:

Sandy;
The entry point should be pic-ph5/register_form.php. Derick, is that still correct?
We tried to do the data restriction in a way similar to the existing web form but i suspect there
will need to be tweaks.
Also, we have 3 experiments here that are ready, or near ready, to be delivered to the
new area. These are relatively new data sets, one from late last year and two from last month.

steve.

#3 Updated by Rob Newman almost 10 years ago

On 2014-04-16 16:26, Mea wrote:

1. When I submit a request the page returns a receipt of request and advices that I will
receive an email. Never got an email. How do I know where my request is and/or what is the status?

2. If array number is a required field, shouldn't that be indicated with an asterisk on the form?

#4 Updated by Rob Newman almost 10 years ago

Begin forwarded message:

From: Derick Hess <>
Subject: Re: hdf5 temporary volume
Date: April 16, 2014 at 3:24:55 PM PDT
To: Mea <>
Cc: Steve Azevedo <>, Rob Newman <>, Sandra Stromme <>, Rick Benson <>

1) The email isnt working. It is being sent by the system but getting lost/not transmitted
somewhere on the DMC server side possibly still a firewall issue. Emails work on all the
other test servers we have set up. Once the issue with the email getting lost is figured
out you should get an email as soon as your request is done with a link to your data.

2) I'll fix that one. For the most part you shouldn't need to type anything at all in the
form except an optional reduction velocity and optional label. It should be inputted for
you when you select it from the data tab.

#5 Updated by Rob Newman almost 10 years ago

On 2014-04-16 17:08, Mea wrote:

Thanks Derrick for your quick reply. Sorry about the email problem, since that is on
our side of things. It's nice that selecting the shots fills in everything except the
duration. It didn't autofill the array which I do think it used to do. Thanks for looking into it.

I have more questions that relate to how the ph5 request functions will interface with the
dmc collection of statistics, verifying, releasing, and crypting restricted data, etc.

1. How are queries to determine if data is restricted or not going to happen?
Unrestricted data does not have a license file. So if the ph5 available list on
Steve's form is drawing from the license file it is not an accurate way to point
to unrestricted data sets.

2. What is the plan to have ph5 requests inserted into our active processing queue and our database?

3. Not sure it's too feasible to have users create and maintain a login to get ph5 data.
Where will these accounts be held and who will be responsible for maintenance?

4. Our license file system was to move from a file based system to a DB based system.
What are you using?

#6 Updated by Rob Newman almost 10 years ago

Begin forwarded message:

From: Derick Hess <>
Subject: Re: hdf5 temporary volume
Date: April 16, 2014 at 4:12:20 PM PDT
To: Mea <>
Cc: Steve Azevedo <>, Rob Newman <>, Sandra Stromme <>, Rick Benson <>

no problem. I'll take a look at the array auto fill issue.

1) If this is the case I can add a column in the database for restricted/unrestricted. I think we
assumed that since inside the license file it specifies restricted or unrestricted that all
experiments had license files. That should be an easy change. I have also coded data restrictions in
two different ways that can be used independent or together. The first system checks the requestors
email and permissions against the license file and stops them from even making a request to save
server processing time. They can still see metadata, but can't complete a request. The 2nd part of the
system encrypts a restricted data request with openssl in the same way it is currently being done.

2) I'm not sure on that one. Sandy gave me some information about sending an email to your system with
some specifics used tracking requests. That has been implemented

3) The user accounts aren't actually necessary for the system to work. We were just using it to store
their information so they wouldn't have to retype it. If that isnt feasible it can be taken out
without any issues.

4) I have actually implemented both ways. I had heard you were moving away from the license file
system so I wrote code to use license system or to ask a database for permissions.

I've tried to make the software as flexible as possible so we can more easily make it work with other
systems currently in place.

#7 Updated by Rob Newman almost 10 years ago

From: Sandra Stromme [mailto:]
Sent: Wednesday, April 16, 2014 4:04 PM
To: Derick Hess
Cc: Mea; Steve Azevedo; Rob Newman; Rick Benson; Inge Watson
Subject: Re: hdf5 temporary volume

HI,

Inge is our sys admin and can help with getting email working. She’ll need to know specifics about
how you’re sending email out. I thought long ago I did receive email from the system, not 100% sure.
Did it used to work and then stop?

Thx,

Sandy

#8 Updated by Rob Newman almost 10 years ago

On 2014-04-16 17:14, Inge Watson wrote:

Can you send me the steps to generate an email through your program and I’ll work on it? Thanks.

-Inge

#9 Updated by Rob Newman almost 10 years ago

Begin forwarded message:

From: Derick Hess <>
Subject: RE: hdf5 temporary volume
Date: April 16, 2014 at 4:22:00 PM PDT
To: Inge Watson <>
Cc: "'Sandra Stromme'" <>, "'Mea'" <>,
"'Steve Azevedo'" <>, "'Rob Newman'" <>,
"'Rick Benson'" <>

Sure. I think it may just be calling the mailhost incorrectly. I've tried a few different ways without
any luck.

basically this is what is happening.

SUBJECT = "PH5 Data Request made" 
TO = 'dhess@passcal.nmt.edu'
FROM = "PIC@iris.washington.edi" 
BODY = "some body test goes here" 

server = smtplib.SMTP('localhost')
server.sendmail(FROM, [TO], BODY)
server.quit()

I've tried sending from Iris.washington.edu as well without any luck. I may have to point it to whatever your main mailhost is.

#10 Updated by Rob Newman almost 10 years ago

On 2014-04-16 17:19, Inge Watson wrote:

Looks like a typo in the configs.... can you try again?

Apr 16 16:15:45 norman.iris.washington.edu sendmail10882: [ID 801593 mail.info] s3GLsjpq008786: to=<>, delay=01:20:42, xdelay=00:00:31, mailer=esmtp, pri=661449, relay=mail.passcal.nmt.edu. [129.138.26.2], dsn=4.1.8, stat=Deferred: 450 4.1.8 <>: Sender address rejected: Domain not found

#11 Updated by Rob Newman almost 10 years ago

On 2014-05-05 16:19, Mea wrote:

Hi Derrick,
I'm just following up on the issues below. Not sure I ever confirmed that
we absolutely do not want to keep the user login feature. (#3) below.

Regardng item 1 below (restricted) We'll create a license file for every ph5 data set
whether it is restricted or open. Those will be the only two categories possible. If
the status field is empty in a ph5 license, the data set should be considered restricted.

Will there be some method of letting us know when a request fails?

Thanks
Mea

#12 Updated by Rob Newman almost 10 years ago

Begin forwarded message:

From: Derick Hess <>
Subject: Re: Fwd: hdf5 temporary volume
Date: May 5, 2014 at 3:34:24 PM PDT
To: Mea <>
Cc: Sandra Stromme <>, Rob Newman <>

I'll take out the account feature. Should have that implemented tomorrow. I get an email form the
system when there might be a problem with some technical information. I can have it send an email to
someone there with whatever information you want as well(maybe email address, report number and when
it was requested).

~Derick

#13 Updated by Rob Newman almost 10 years ago

  • Status changed from New to In Progress

#14 Updated by Derick Hess almost 10 years ago

  • Resolution set to Fixed
  • % Done changed from 0 to 100
  • Status changed from In Progress to Resolved

Also available in: Atom PDF