Project

General

Profile

Bug #551

Ph5 request form problems

Added by Rob Newman almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
07/10/2014
Due date:
% Done:

100%

Estimated time:
8.00 h
Resolution:
Fixed

Description

Sent on behalf of Mea - Issues using PH5 interface form:

1. By Event ID returns following message:
Shot Range, recevier ID and time length required. Please press the back button and try again
but there is nowhere on the form to put this information.

2. startime format in arrays is different than required on request form. Maybe you could make the
additional sec.xxxx autofill? Also, form only requires a start time, but when submitted returns:

Arrays, length and start time are required. Please press the back button and try again

Using back button seems to load a new form page which no longer includes the start time. Adding arrays and length to this page returns:

Arrays, length and start time are required. Please press the back button and try again

so stuck in a loop.

3. Does every PH5 data set need a license file, including those data sets which are NOT restricted from the start?
requesting unrestricted data sets currently returns this message. It is ok to set it up that way, but we need to know
so that a license file will be part of our data setup.

4. Log info after request submission should be sent to user in an email, so that request form is exited. Maybe only a banner page, which tells the user request was received and email with log information will be sent momentarily.

5. Red River, 10-016 is marked as restricted at http://www.iris.edu/pic-ph5/experiment_list.php. It is not restricted.

Other Issues:

  1. I will need to be notified when ph5 data becomes available so that I can populate our db and create a license file.
  2. Restricted data that is given to users needs to be encrypted.
  3. Where will users pick up the data?
  4. I have sent requests, but never received email that data was ready.????

History

#1 Updated by Derick Hess almost 10 years ago

1) which event id type of request is it.? Event order or receiver order? The error messages may be mixed up. I'll take a look and fix it.

2 )I think the 2nd error is caused by the way different browsers handle pressing back. On some browsers it fully resets the form and on some it doesn't. I think the best way to make sure the error doesn't happen is I will re write all the error messages and have them click a link that fully resets the form so the back button issue doesnt occur.

3) I thought we had discussed that if an experiment doesn't have a license file it is assumed to be restricted. The original way is unrestricted. The only way for the system to know for sure if it unrestricted or restricted is to have a license file. Otherwise an assumption has to be made.

4) That can be done. The live log file was originally so I could see how a request was being fulfilled and a few users liked that so I kept it. That can be taken out, and either the log file can be included with the data or can be emailed separately.

5) That is assumed restricted because there is no license file for the experiment.

other issues:
1) that is already in place with the new upload system. When someone uploads a new experiment you will get an email with all the information about the experiment as well as who added it.
2) That already happens using the method sandy provided
3) users get a link to download the data that is good for 30 days
4) That was probably my fault as I was making changes to the system to allow for a new back end error system that will email you, me and anyone else who we want to add for potential errors. The email will contain a link to page describing the request and what the error is. Either of us will be able to type in notes about the error if we want as well as mark it as resolved or urgent.

I should have all of these issues and the new error system up and ready to test by monday.

#2 Updated by Derick Hess almost 10 years ago

  • Resolution set to Fixed
  • Estimated time set to 8.00 h
  • % Done changed from 0 to 100
  • Status changed from New to Resolved

Also available in: Atom PDF