Project

General

Profile

Bug #606

Miscellaneous updates to logging and some message content

Added by Mike Stults almost 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
10/01/2014
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed

Description

- A WSS timeout can occur before a handler sends data or before, add log message to help determine which type of timeout occurred.
- Correct spelling in message appended to datastream in case of timeout, "likley" to likely.
- Update miniseed log message for parsing error with bytes written count.
- Change one or a few 500 errors to 4xx to make the errors more informative and reduce the amount of generic exceptions the Jersey framework writes to catalina.out.
- Change the constructor for throwing exceptions to the framework to include a Throwable message.
- Add messages form WSS when a handler process does not provide stderr information.

WSS_timeout606.txt (1008 Bytes) WSS_timeout606.txt Robert Weekly, 10/30/2014 08:55 AM

History

#1 Updated by Mike Stults almost 10 years ago

several messages were changed to make the messages more consistent from message to message. Included are a few more phrases about information from handler and/or lack of error messages from handler. More messages should include a caused by phrase when chained exceptions occur

Changing any errors from 500 to 4xx was not done as 4xx are to reflect state of client, not server.

#2 Updated by Robert Weekly over 9 years ago

A WSS timeout can occur before a handler sends data or before, add log message to help determine which type of timeout occurred.

This is confirmed (details attached). Tested with one handler that sends text and then goes to sleep, and another handler with the "opposite" behavior (i.e., sleep before any data transmission).

Correct spelling in message appended to datastream in case of timeout, "likley" to likely.

Confirmed that the typo has been fixed.

Update miniseed log message for parsing error with bytes written count.

Confirmed that dataselect.log now includes a count of bytes written along with the amount of time (in ms) it took.
INFO ProcessStreamingOutput - writeMiniSeed done: Wrote 7168 bytes processingTime: 8309 timeNotBlocking: 27

Change one or a few 500 errors to 4xx to make the errors more informative and reduce the amount of generic exceptions the Jersey framework writes to catalina.out.

Not tested according to follow-up note.

Change the constructor for throwing exceptions to the framework to include a Throwable message.

Not tested yet.

Add messages form WSS when a handler process does not provide stderr information.

Not tested yet.

#4 Updated by Robert Weekly over 9 years ago

As a summary, the first three items listed in the ticket were tested and confirmed, but the other issues were not explicitly tested for as they did not affect the functionality of WSS.

Unfortunately, I may lack the technical understanding of how the WSS interacts with handlers to properly test the last item (re: handler processes not providing stderr).

#5 Updated by Robert Weekly over 9 years ago

  • Resolution set to Fixed
  • Status changed from New to Closed

Remaining issues have been addressed in second round of testing for ver. 1.1.9-SNAPSHOT.

Closed.

Also available in: Atom PDF