Project

General

Profile

Feature #799

Query latency

Added by Oscar Javier HIguera Benavides almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Start date:
03/17/2016
Due date:
% Done:

0%

Estimated time:
Resolution:
Not a Bug

Description

Estamos compartiendo las estaciones desde el software SeisComp3 a través del Ringserver, pero si visualizo las señales SeisComp3 a Seiscomp3, tienen una latencia de segundos, pero con el Ringserver, la latencia del servidor es casi de 4 minutos, que puedo hacer para disminuir la latencia.

Gracias.

We are sharing the stations from the SeisComp3 software through Ringserver, but if I view the SeisComp3 signals SeisComp3 have a latency of seconds, but with Ringserver, server latency is almost 4 minutes, I can do to decrease latency .

Thank you.

Oscar

ringserver.PNG (33.4 KB) ringserver.PNG Oscar Javier HIguera Benavides, 03/17/2016 11:35 AM

History

#2 Updated by Chad Trabant almost 8 years ago

  • Status changed from New to In Progress
  • Tracker changed from Bug to Feature

Hi Oscar,

You will have to provide more details before we can make any further suggestions. Most importantly: how is the data transmitted between the SC3 system and ringserver?

Ringserver itself should add very little latency to each data packet, assuming the resources of the machine or network are not saturated (i.e. too busy).

#3 Updated by Oscar Javier HIguera Benavides almost 8 years ago

Tank you answer.

Nosotros tenemos un seiscomp3 que almacena los datos del archive en una NAS, esta NAS esta separada del sistema operativo, instale el ringserver normal, comparto estaciones correctamente, pero al conectarme directamente al seedlink de seiscomp3 tengo una latencia de segundos, al hacerlo desde el ringserver, muestra tiempos de más de 4 minutos, como lo ilustre en la gráfica.

Necesitas las especificaciones físicas de la maquina?.

We have a SeisComp3 that stores the file data on a NAS, the NAS is separate from the operating system, install the normal ringserver, share stations correctly, but to connect directly to SEEDLINK of SeisComp3 have a latency of seconds, doing so from the ringserver shows time longer than 4 minutes, as distinguished on the graph.
You need the physical specifications of the machine ?.

#4 Updated by Chad Trabant almost 8 years ago

I need to know how the data get into ringserver.

You have a NAS where SC3 writes the data. Does the ringserver then scan the data files from that same NAS system? Are you using the miniSEED scanning function built into ringserver? If so, that can add a lot of latency depending on how many data files it is scanning. Such scanning is not recommended for a large archive of data, but instead is mean only for near real-time data.

An alternative to scanning files is to use slink2dali (SeedLink to DataLink) to collect data from a SeedLink server and push it into a ringserver. The source code can be found here:
http://ds.iris.edu/pub/programs/ringserver/

In this case you would set up slink2dali to collect data from the SC3 SeedLink interface and transmit it to your ringserver.

The physical specifications of the machine are not needed, only to know that the machine is not extremely busy.

#5 Updated by Oscar Javier HIguera Benavides almost 8 years ago

According to the comments, I see that I am actually scanning all my files, that may be the problem, I'm scanning the entire directory from the ringserver.

I wanted to ask, there is a manual to install or configure the slink2dali, I should consider to set it up.

Tank's

#6 Updated by Chad Trabant almost 8 years ago

  • Resolution set to Not a Bug
  • Status changed from In Progress to Resolved

There is a man page for slink2dali in the doc directory included with the source code.

Also available in: Atom PDF